<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]--><head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="http://www.thecommercialrecord.com/xmlrpc.php">

<!-- Retina Logo-->
		<style type="text/css" >
		@media only screen and (-webkit-min-device-pixel-ratio: 2),(min-resolution: 192dpi) {
			/* Retina Logo */
			.primary-logo{background:url(http://www.thecommercialrecord.com/wp-content/uploads/2016/04/toplogo_cr.gif) no-repeat center; display:inline-block !important; background-size:contain;}
			.primary-logo img{ opacity:0; visibility:hidden}
			.primary-logo *{display:inline-block}
		}
	</style>
	
	<meta property="og:image" content="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/green-coy.jpg"/>
	<meta property="og:title" content="Re-envisioned carwash is new marijuana home"/>
	<meta property="og:url" content="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/"/>
	<meta property="og:site_name" content="The Commercial Record"/>
	<meta property="og:type" content="article"/>
	<meta property="og:description" content="BY SCOTT SULLIVAN
EDITOR
Two summers ago we met
Dave Setzke as he camped
on the first of 10 squares
painted on the Douglas City
Hall lawn, waiting to apply
fo"/>
    <meta property="fb:app_id" content="" />
	<meta property="description" content="BY SCOTT SULLIVAN
EDITOR
Two summers ago we met
Dave Setzke as he camped
on the first of 10 squares
painted on the Douglas City
Hall lawn, waiting to apply
fo"/>
	<title>Re-envisioned carwash is new marijuana home &#8211; The Commercial Record</title>
<link rel="alternate" type="application/rss+xml" title="The Commercial Record &raquo; Feed" href="http://www.thecommercialrecord.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Commercial Record &raquo; Comments Feed" href="http://www.thecommercialrecord.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/www.thecommercialrecord.com\/wp-includes\/js\/wp-emoji-release.min.js"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;if(!g||!g.fillText)return!1;switch(g.textBaseline="top",g.font="600 32px Arial",a){case"flag":return g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3;case"diversity":return g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,d=c[0]+","+c[1]+","+c[2]+","+c[3],g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e;case"simple":return g.fillText(h(55357,56835),0,0),0!==g.getImageData(16,16,1,1).data[0];case"unicode8":return g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0]}return!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i;for(i=Array("simple","flag","unicode8","diversity"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='dashicons-css'  href='http://www.thecommercialrecord.com/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='wunderground-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/wunderground/assets/css/wunderground.css' type='text/css' media='all' />
<link rel='stylesheet' id='ct_shortcode_style-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/newstube-shortcodes/shortcodes/css/shortcode.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-jquery-ui-dialog-css'  href='http://www.thecommercialrecord.com/wp-includes/css/jquery-ui-dialog.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='layerslider-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/LayerSlider/static/css/layerslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='ls-google-fonts-css'  href='http://fonts.googleapis.com/css?family=Lato:100,300,regular,700,900%7COpen+Sans:300%7CIndie+Flower:regular%7COswald:300,regular,700&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='video-ads-management-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/cactus-ads/css/video-ads-management.css' type='text/css' media='all' />
<link rel='stylesheet' id='cactus-poll-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/cactus-poll/css/cactus-poll.css' type='text/css' media='all' />
<link rel='stylesheet' id='truemag-rating-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/cactus-rating//css/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/cactus-rating/css/animate.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/contact-form-7/includes/css/styles.css' type='text/css' media='all' />
<link rel='stylesheet' id='easy-tab-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/easy-tab/tab.css' type='text/css' media='all' />
<link rel='stylesheet' id='style2-os-css-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/gallery-video/style/style2-os.css' type='text/css' media='all' />
<link rel='stylesheet' id='lightbox-css-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/gallery-video/style/lightbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='videogallery-all-css-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/gallery-video/style/videogallery-all.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/gallery-video/style/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/revslider/public/assets/css/settings.css' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='bootstrap-css'  href='http://www.thecommercialrecord.com/wp-content/themes/newstube/css/bootstrap.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mashmenu-css-css'  href='http://www.thecommercialrecord.com/wp-content/themes/newstube/inc/megamenu/css/mashmenu.css' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='http://www.thecommercialrecord.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='swiper-css'  href='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/swiper/idangerous.swiper.css' type='text/css' media='all' />
<link rel='stylesheet' id='newstube-css-css'  href='http://www.thecommercialrecord.com/wp-content/themes/newstube/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='malihu-scroll-css'  href='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/malihu-scroll/jquery.mCustomScrollbar.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cactus-style-css'  href='http://www.thecommercialrecord.com/wp-content/themes/newstube-child/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C800%2C400italic%2C800italic' type='text/css' media='all' />
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/core.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/widget.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/position.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/menu.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/wp-a11y.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No search results.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate."};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/autocomplete.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WuWidget = {"apiKey":"3ffab52910ec1a0e","_wpnonce":"58e7276dbb","ajaxurl":"http:\/\/www.thecommercialrecord.com\/wp-admin\/admin-ajax.php","is_admin":"","subdomain":"www"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/wunderground/assets/js/widget.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/LayerSlider/static/js/greensock.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/LayerSlider/static/js/layerslider.kreaturamedia.jquery.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/LayerSlider/static/js/layerslider.transitions.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/easy-tab/tab.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var cactus = {"ajaxurl":"http:\/\/www.thecommercialrecord.com\/wp-admin\/admin-ajax.php","query_vars":{"page":0,"name":"re-envisioned-carwash-is-new-marijuana-home","error":"","m":"","p":0,"post_parent":"","subpost":"","subpost_id":"","attachment":"","attachment_id":0,"pagename":"","page_id":0,"second":"","minute":"","hour":"","day":0,"monthnum":0,"year":0,"w":0,"category_name":"","tag":"","cat":"","tag_id":"","author":"","author_name":"","feed":"","tb":"","paged":0,"meta_key":"","meta_value":"","preview":"","s":"","sentence":"","title":"","fields":"","menu_order":"","embed":"","category__in":[],"category__not_in":[],"category__and":[],"post__in":[],"post__not_in":[],"post_name__in":[],"tag__in":[],"tag__not_in":[],"tag__and":[],"tag_slug__in":[],"tag_slug__and":[],"post_parent__in":[],"post_parent__not_in":[],"author__in":[],"author__not_in":[],"ignore_sticky_posts":false,"suppress_filters":false,"cache_results":true,"update_post_term_cache":true,"update_post_meta_cache":true,"post_type":"","posts_per_page":10,"nopaging":false,"comments_per_page":"50","no_found_rows":false,"order":"DESC"},"current_url":"http:\/\/www.thecommercialrecord.com\/re-envisioned-carwash-is-new-marijuana-home"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/ajax.js'></script>
<link rel='https://api.w.org/' href='http://www.thecommercialrecord.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.thecommercialrecord.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.thecommercialrecord.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Schools offer last pre-vote tours Saturday' href='http://www.thecommercialrecord.com/schools-offer-last-pre-vote-tours-saturday/' />
<link rel='next' title='Police investigate Laketown death' href='http://www.thecommercialrecord.com/police-investigate-laketown-death/' />
<meta name="generator" content="WordPress 4.5.20" />
<link rel="canonical" href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/" />
<link rel='shortlink' href='http://www.thecommercialrecord.com/?p=18170' />
<link rel="alternate" type="application/json+oembed" href="http://www.thecommercialrecord.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.thecommercialrecord.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&#038;format=xml" />
<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="http://www.thecommercialrecord.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><!--[if IE  8]><link rel="stylesheet" type="text/css" href="http://www.thecommercialrecord.com/wp-content/plugins/js_composer/assets/css/vc-ie8.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.1.6 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<!-- custom css -->
				<style type="text/css">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</style>
			<!-- end custom css --><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body class="single single-post postid-18170 single-format-standard  group-blog wpb-js-composer js-comp-ver-4.11.2.1 vc_responsive">	
	 <style type="text/css" rel="stylesheet" scoped>#body-wrap{background: url(http://www.thecommercialrecord.com/wp-content/uploads/2016/04/2-Ariel-View-Saugatuck-Credit-Ted-Swoboda.jpg) center center no-repeat fixed ;}</style><div id="body-wrap" class="">
    <div id="wrap">
        <header class="">
    	
<!--Navigation style-->
<div class="cactus-nav ">

    <!--Top NAV-->
    <div id="top-nav">

    <nav class="navbar navbar-default" role="navigation">
        <div class="container">
            <!--Headlines-->
                         <!--Headlines-->
            			<ul class="nav navbar-nav navbar-right top-menu-rps cactus-login">                	                 
                <li>   
                	                                      
                    	<a href="http://www.thecommercialrecord.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F">login</a>
                                    </li>                                       
            </ul>
            	
            <!--Share list-->
           		<ul class='nav navbar-nav navbar-right social-listing list-inline social-accounts'>
						<li class="facebook"><a target='_blank' href="https://www.facebook.com/thecommercialrecord/" title='Facebook'><i class="fa fa-facebook"></i></a></li>
																																		<li class="rss"><a target='_blank' href="http://www.thecommercialrecord.com/feed" title='RSS'><i class="fa fa-rss"></i></a></li>
						        		</ul>
		            <!--Share list-->

            <!--Menu-->
            <ul class="nav navbar-nav navbar-right rps-hidden top-menu-rps">
                <li id="menu-item-6988" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6988"><a href="http://www.thecommercialrecord.com/advertise/">Advertise</a></li>
<li id="menu-item-157" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157"><a href="http://www.etypeservices.com/Kaechele%20PublicationsID459/">E-Edition</a></li>
<li id="menu-item-6992" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6992"><a href="http://www.thecommercialrecord.com/subscribe-2/">Subscribe</a></li>
<li id="menu-item-154" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="http://www.thecommercialrecord.com/contact/">Contact</a></li>
<li id="menu-item-6990" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6990"><a href="http://www.thecommercialrecord.com/community-links/">Community Links</a></li>
            </ul><!--Menu-->

            <!--mobile-->
                                <ul class="open-menu-mobile-top nav navbar-nav navbar-right">
                        <li>
                            <a href="javascript:;"> <span></span><span></span><span></span></a>
                            <!--Submenu-->
                            <ul class="dropdown-menu">
                                <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6988"><a href="http://www.thecommercialrecord.com/advertise/">Advertise</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-157"><a href="http://www.etypeservices.com/Kaechele%20PublicationsID459/">E-Edition</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6992"><a href="http://www.thecommercialrecord.com/subscribe-2/">Subscribe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-154"><a href="http://www.thecommercialrecord.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6990"><a href="http://www.thecommercialrecord.com/community-links/">Community Links</a></li>
                            </ul>
                            <!--Submenu-->
                        </li>
                    </ul>
                        <!--mobile-->

        </div>
    </nav>

</div>    <!--Top NAV-->

    <!--Branding-->
    <div id="main-nav" class="nav-branding">
    <nav class="navbar navbar-default" role="navigation">
        <div class="container">

            <!--Logo-->
            <div class="navbar-header">
                <!--logo-->
                <a class="navbar-brand" href="http://www.thecommercialrecord.com">
                    <div class="primary-logo">
                                                <img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/04/toplogo_cr.gif" alt="The Commercial Record" title="The Commercial Record">
                    </div>
                </a><!--logo-->
            </div><!--Logo-->
                            <ul class="nav navbar-nav navbar-right rps-hidden cactus-header-ads">
                    <li>                    <div class='ad ads_top_nav'><a href="http://www.shorelinerealtors.com"><img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/05/shorelineBanner.jpg"/></div>
        	</li>
                </ul>
            
        </div>
    </nav>
</div>    <!--Branding-->

    <!--Primary menu-->
    <div id="main-menu">

    <nav class="navbar navbar-default " role="navigation">
        <div class="container">
            <div class="main-menu-wrap">
                                <ul class="nav navbar-nav cactus-logo-nav is-sticky-menu">
                    <li><a href="http://www.thecommercialrecord.com"><img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/04/toplogo_cr.gif" alt="The Commercial Record" title="The Commercial Record"></a></li>
                </ul>
                                <ul class="nav navbar-nav open-menu-mobile">
                  <li class="show-mobile open-menu-mobile-rps"><a href="javascript:;"><i class="fa fa-bars"></i></a></li>
                </ul>
                
                                <!--HTML Struc (truemag)-->
                <ul class="nav navbar-nav cactus-main-menu ">
                    <li id="nav-menu-item-128" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-home"><a href="http://www.thecommercialrecord.com/" class="menu-link  main-menu-link">Home </a></li>
<li id="nav-menu-item-129" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children parent dropdown"><a href="http://www.thecommercialrecord.com/category/news/" class="menu-link dropdown-toggle disabled main-menu-link" data-toggle="dropdown">News </a>
<ul class="dropdown-menu menu-depth-1">
	<li id="nav-menu-item-7026" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.thecommercialrecord.com/category/news/sports/aroundtownsports/" class="menu-link  sub-menu-link">Around Town </a></li>
	<li id="nav-menu-item-7024" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.thecommercialrecord.com/category/news/localnews/" class="menu-link  sub-menu-link">Local </a></li>
	<li id="nav-menu-item-7028" class="sub-menu-item menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.thecommercialrecord.com/category/contributed/" class="menu-link  sub-menu-link">Contributed </a></li>

</ul>
</li>
<li id="nav-menu-item-6995" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.thecommercialrecord.com/category/news/sports/" class="menu-link  main-menu-link">Sports </a></li>
<li id="nav-menu-item-6996" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.thecommercialrecord.com/category/opinion/" class="menu-link  main-menu-link">Opinion </a></li>
<li id="nav-menu-item-6997" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="http://www.thecommercialrecord.com/obituaries/" class="menu-link  main-menu-link">Obituaries </a></li>
<li id="nav-menu-item-6998" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.allegannews.com/" class="menu-link  main-menu-link">Allegan News </a></li>
<li id="nav-menu-item-6999" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.allegannews.com/union-enterprise" class="menu-link  main-menu-link">Union Enterprise </a></li>
<li id="nav-menu-item-7782" class="main-menu-item menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://www.thecommercialrecord.com/category/classified/" class="menu-link  main-menu-link">Classified </a></li>
                </ul>
                <!--HTML Struc (truemag)-->
				                                <!--Search-->
                <ul class="nav navbar-nav navbar-right search-drop-down dark-div">
                    <li>
                        <a href="javascript:;" class="open-search-main-menu"><i class="fa fa-search"></i><i class="fa fa-times"></i></a>
                        <ul class="search-main-menu">
                            <li>
                                <form action="http://www.thecommercialrecord.com" method="get">
                                    <input type="hidden" name="post_type" value="post">
                                    <input type="text" placeholder="Search..." name="s" value="">
                                    <i class="fa fa-search"></i>
                                    <input type="submit" value="search">
                                </form>
                            </li>
                        </ul>
                    </li>
                </ul>
                <!--Search-->
				            </div>
        </div>
    </nav>
	<input type="hidden" name="sticky_navigation" value="on"/>
</div>    <!--Primary menu-->

</div>
<!--Navigation style-->
        </header>
        
        <div class="main-top-sidebar-wrap"><div id="text-9" class=" body-widget widget_text"><div class="body-widget-inner">			<div class="textwidget"></div>
		</div></div></div>
    <div id="cactus-body-container"> <!--Add class cactus-body-container for single page-->
        <div class="cactus-single-page cactus-sidebar-control sb-right  ">
            <div class="container">
                <div class="row">
					                    <div class="main-content-col col-md-12 cactus-config-single">
						                        
                        <!--breadcrumb-->
                        <div class="cactus-breadcrumb" xmlns:v="http://rdf.data-vocabulary.org/#"><a href="http://www.thecommercialrecord.com/" rel="v:url" property="v:title">Home</a> <i class="fa fa-angle-right"></i> <span typeof="v:Breadcrumb"><a rel="v:url" property="v:title" href="http://www.thecommercialrecord.com/category/around-town/">Around Town</a></span> <i class="fa fa-angle-right"></i> <span class="current">Re-envisioned carwash is new marijuana home</span></div><!-- .breadcrumbs -->                        <!--breadcrumb-->
                                                <div id='single-post' class="single-post-content">
                                                                                    <article data-id="18170" data-url='http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/' data-timestamp='1582827552' data-count='0' data-enable-fb-comment='0' id="post-18170" class="cactus-single-content post-18170 post type-post status-publish format-standard has-post-thumbnail hentry category-around-town category-community category-featured-stories category-local" >
                                    											<div class="style-post">
    	                            <img src="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/green-coy.jpg" alt="Re-envisioned carwash is new marijuana home" class="featured">
                                    </div>
    		<div class="heading-post">                                            
			<!--info-->
			<div class="posted-on">
						        	
				<div class="cactus-note-cat"><a href="http://www.thecommercialrecord.com/category/around-town/" title="View all posts in Around Town">Around Town</a>
                </div>		        	
				<div class="cactus-note-cat"><a href="http://www.thecommercialrecord.com/category/community/" title="View all posts in Community">Community</a>
                </div>		        	
				<div class="cactus-note-cat"><a href="http://www.thecommercialrecord.com/category/news/featured-stories/" title="View all posts in Featured Stories">Featured Stories</a>
                </div>		        	
				<div class="cactus-note-cat"><a href="http://www.thecommercialrecord.com/category/local/" title="View all posts in Local">Local</a>
                </div>							<div class="fix-responsive"></div>
				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>				<span class="vcard author"> 
					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
				</span>
				<a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/#respond" class="comment cactus-info">0</a>                                               
			</div><!--info-->
			
			<!--Title-->
			<h1 class="h3 title entry-title">
									Re-envisioned carwash is new marijuana home										
			</h1>
			<!--Title-->
			
		</div>
		    		<div class="update_design_post_on">
			<div class="posted-on">       
								<a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/#respond" class="comment cactus-info">0</a>
			</div>
		</div>
		
				
		<div class="cactus-share-and-like ">
						<a class="share-tool-block open-cactus-share" data-toggle="tooltip" data-placement="top" href="javascript:;" title="" data-original-title="social share">
				<i class="fa fa-share-alt"></i>
				<i class="fa fa-times"></i>
							</a>
												
						
						<a href="javascript:;" class="share-tool-block open-carousel-listing pull-right">more&nbsp; <i class="fa fa-angle-down"></i></a>
						<div class="clearfix"></div>
	
			<!--Share-->
								<ul class="social-listing list-inline change-color">
	  				  		<li class="facebook">
		  		 	<a class="trasition-all" title="Share on Facebook" href="#" target="_blank" rel="nofollow" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+'http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','facebook-share-dialog','width=626,height=436');return false;"><i class="fa fa-facebook"></i>
		  		 	</a>
		  		</li>
	    			    	<li class="twitter">
			    	<a class="trasition-all" href="#" title="Share on Twitter" rel="nofollow" target="_blank" onclick="window.open('http://twitter.com/share?text=Re-envisioned+carwash+is+new+marijuana+home&amp;url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','twitter-share-dialog','width=626,height=436');return false;"><i class="fa fa-twitter"></i>
			    	</a>
		    	</li>
	    					   	<li class="linkedin">
				   	 	<a class="trasition-all" href="#" title="Share on LinkedIn" rel="nofollow" target="_blank" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;title=Re-envisioned+carwash+is+new+marijuana+home&amp;source=The+Commercial+Record','linkedin-share-dialog','width=626,height=436');return false;"><i class="fa fa-linkedin"></i>
				   	 	</a>
				   	</li>
		   				   	<li class="tumblr">
			   	   <a class="trasition-all" href="#" title="Share on Tumblr" rel="nofollow" target="_blank" onclick="window.open('http://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;name=Re-envisioned+carwash+is+new+marijuana+home','tumblr-share-dialog','width=626,height=436');return false;"><i class="fa fa-tumblr"></i>
			   	   </a>
			   	</li>
	    			    	 <li class="google-plus">
		    	 	<a class="trasition-all" href="#" title="Share on Google Plus" rel="nofollow" target="_blank" onclick="window.open('https://plus.google.com/share?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','googleplus-share-dialog','width=626,height=436');return false;"><i class="fa fa-google-plus"></i>
		    	 	</a>
		    	 </li>
	    	 		    	 <li class="pinterest">
		    	 	<a class="trasition-all" href="#" title="Pin this" rel="nofollow" target="_blank" onclick="window.open('//pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;media=http%3A%2F%2Fwww.thecommercialrecord.com%2Fwp-content%2Fuploads%2F2020%2F02%2Fgreen-coy.jpg&amp;description=Re-envisioned+carwash+is+new+marijuana+home','pin-share-dialog','width=626,height=436');return false;"><i class="fa fa-pinterest"></i>
		    	 	</a>
		    	 </li>
	    	 		    	 <li class="vk">
		    	 	<a class="trasition-all" href="#" title="Share on VK" rel="nofollow" target="_blank" onclick="window.open('//vkontakte.ru/share.php?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','vk-share-dialog','width=626,height=436');return false;"><i class="fa fa-vk"></i>
		    	 	</a>
		    	 </li>
	    	 		    	<li class="email">
			    	<a class="trasition-all" href="mailto:?subject=Re-envisioned+carwash+is+new+marijuana+home&amp;body=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F" title="Email this"><i class="fa fa-envelope"></i>
			    	</a>
			   	</li>
		   		    </ul>
        						<!--Share-->
		</div>
	
					<!--listing video-->
			<div class="cactus-transition-open">
				<div class="cactus-listing-carousel">
					<a class="pre-carousel" href="javascript:;"><i class="fa fa-angle-left"></i></a>
					<a class="next-carousel" href="javascript:;"><i class="fa fa-angle-right"></i></a>
					<div class="pagination"></div>
					<div class="cactus-listing-carousel-content">
						<!--Listing-->
						<div class="cactus-listing-wrap">
							<!--Config-->
							<div class="cactus-listing-config style-1 style-3"> <!--addClass: style-1 + (style-2 -> style-n)-->
	
								<div class="container">
									<div class="row">
	
										<div class="col-md-12 cactus-listing-content"> <!--ajax div-->
	
											<div class="cactus-sub-wrap">
												<div class="cactus-swiper-container" data-settings='["mode":"cactus-fix-composer"]'>
													<div class="swiper-wrapper">
													<!--Now playing item-->
														<div class="swiper-slide ">
															<!--item listing-->
															<div class="cactus-post-item hentry active">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																				<!--picture-->
																		<div class="picture">
																			<div class="picture-content">
																				<a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/" title="Re-envisioned carwash is new marijuana home">
																					<img src="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/green-coy-253x189.jpg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/green-coy-253x189.jpg 253w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/green-coy-760x570.jpg 760w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/green-coy-380x285.jpg 380w"
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="green coy"/>																					<div class="thumb-overlay"></div>
																					<i class="fa fa-play-circle-o cactus-icon-fix"></i>
																					<div class="cactus-now-playing"> now viewing</div>
																				</a>
																			</div>
	
																		</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/" title="">Re-envisioned carwash is new marijuana home</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													<!--End playing item-->
																											<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																					<!--picture-->
																			<div class="picture">
																				<div class="picture-content">
																					<a href="http://www.thecommercialrecord.com/police-investigate-laketown-death/" title="Police investigate Laketown death">
																						<img src="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Mandy-H-253x189.jpeg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Mandy-H-253x189.jpeg 253w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Mandy-H-286x215.jpeg 286w"
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="Mandy H"/>																						<div class="thumb-overlay"></div>
																																												<div class="cactus-now-playing"> now playing</div>
																					</a>
																				</div>
		
																			</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/police-investigate-laketown-death/" title="Police investigate Laketown death">Police investigate Laketown death</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																					<!--picture-->
																			<div class="picture">
																				<div class="picture-content">
																					<a href="http://www.thecommercialrecord.com/schools-offer-last-pre-vote-tours-saturday/" title="Schools offer last pre-vote tours Saturday">
																						<img src="http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-253x168.jpg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-253x168.jpg 253w, http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-250x165.jpg 250w, http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-103x68.jpg 103w"
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="sps"/>																						<div class="thumb-overlay"></div>
																																												<div class="cactus-now-playing"> now playing</div>
																					</a>
																				</div>
		
																			</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/schools-offer-last-pre-vote-tours-saturday/" title="Schools offer last pre-vote tours Saturday">Schools offer last pre-vote tours Saturday</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/home-values-are-on-the-rise-across-detroit/" title="Home Values Are On The Rise Across Detroit">Home Values Are On The Rise Across Detroit</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/michigan-adoption-agency-to-stop-international-adoptions-program/" title="Michigan Adoption Agency To Stop International Adoptions Program">Michigan Adoption Agency To Stop International Adoptions Program</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/great-lake-water-levels-set-to-break-another-record-for-february/" title="Great Lake Water Levels Set To Break Another Record For February">Great Lake Water Levels Set To Break Another Record For February</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/douglas-za-imus-resigns/" title="Douglas ZA Imus resigns">Douglas ZA Imus resigns</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																					<!--picture-->
																			<div class="picture">
																				<div class="picture-content">
																					<a href="http://www.thecommercialrecord.com/ambulance-price-rise-may-just-be-start/" title="Ambulance price rise may just be start">
																						<img src="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/amr-253x189.jpg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/amr-253x189.jpg 253w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/amr-380x285.jpg 380w"
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="amr"/>																						<div class="thumb-overlay"></div>
																																												<div class="cactus-now-playing"> now playing</div>
																					</a>
																				</div>
		
																			</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/ambulance-price-rise-may-just-be-start/" title="Ambulance price rise may just be start">Ambulance price rise may just be start</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																					<!--picture-->
																			<div class="picture">
																				<div class="picture-content">
																					<a href="http://www.thecommercialrecord.com/city-taps-kenney-to-fill-open-council-seat/" title="City taps Kenney to fill open council seat">
																						<img src="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Douglas-village-logo-190x189.jpg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Douglas-village-logo-190x189.jpg 190w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Douglas-village-logo-150x150.jpg 150w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Douglas-village-logo-40x40.jpg 40w"
     			sizes="(max-width: 190px) 100vw, 190px"
				alt="Douglas-village-logo"/>																						<div class="thumb-overlay"></div>
																																												<div class="cactus-now-playing"> now playing</div>
																					</a>
																				</div>
		
																			</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/city-taps-kenney-to-fill-open-council-seat/" title="City taps Kenney to fill open council seat">City taps Kenney to fill open council seat</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																					<!--picture-->
																			<div class="picture">
																				<div class="picture-content">
																					<a href="http://www.thecommercialrecord.com/douglas-weighs-funding-balance-of-water-bid/" title="Douglas weighs funding balance of water bid">
																						<img src="http://www.thecommercialrecord.com/wp-content/uploads/2018/02/water-253x182.jpg"
     			srcset=""
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="water"/>																						<div class="thumb-overlay"></div>
																																												<div class="cactus-now-playing"> now playing</div>
																					</a>
																				</div>
		
																			</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/douglas-weighs-funding-balance-of-water-bid/" title="Douglas weighs funding balance of water bid">Douglas weighs funding balance of water bid</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 														<div class="swiper-slide">
															<!--item listing-->
															<div class="cactus-post-item hentry">
																<!--content-->
																<div class="entry-content">
																	<div class="primary-post-content"> <!--addClass: related-post, no-picture -->
																																					<!--picture-->
																			<div class="picture">
																				<div class="picture-content">
																					<a href="http://www.thecommercialrecord.com/douglas-finalizes-marijuana-oks/" title="Douglas finalizes marijuana OKs">
																						<img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/05/marijuana-253x189.jpg"
     			srcset=""
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="marijuana"/>																						<div class="thumb-overlay"></div>
																																												<div class="cactus-now-playing"> now playing</div>
																					</a>
																				</div>
		
																			</div><!--picture-->
																																				<div class="content">
	
																			<!--Title-->
																			<h3 class="h6 cactus-post-title entry-title">
																				<a href="http://www.thecommercialrecord.com/douglas-finalizes-marijuana-oks/" title="Douglas finalizes marijuana OKs">Douglas finalizes marijuana OKs</a>
																			</h3><!--Title-->
																			<div class="posted-on">
																				<div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:19:12+00:00" class="entry-date updated">February 27, 2020</time></div>																				<span class="vcard author"> 
																					<span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" title="Posts by Publisher" rel="author">Publisher</a></span>
																				</span>
																			</div>
	
																			<div class="cactus-last-child"></div> <!--fix pixel no remove-->
																		</div>
																	</div>
	
																</div><!--content-->
	
															</div><!--item listing-->
														</div>
													 	
													</div>
												</div>
	
											</div>
	
										</div>
	
									</div>
								</div>
	
							</div><!--Config-->
						</div><!--Listing-->
					</div>
				</div>
			</div>
			<!--listing video-->
		    
	<div class="body-content " >
    	
		<p>BY SCOTT SULLIVAN<br />
EDITOR<br />
Two summers ago we met<br />
Dave Setzke as he camped<br />
on the first of 10 squares<br />
painted on the Douglas City<br />
Hall lawn, waiting to apply<br />
for the first of two newlyavailable<br />
medical marijuana<br />
licenses.<br />
Last week we visited what<br />
he and business partner<br />
Ethan Del Stone have created<br />
with their permit: Green<br />
Koi at 435 Blue Star Hwy.,<br />
in the old Bearco Car Wash.<br />
“A lot of people,” said Del<br />
Stone, who like his friend<br />
Setzke resides in Douglas,<br />
“thought we’d tear down the<br />
carwash and start from<br />
scratch. But the structure<br />
had good concrete bones,<br />
plus a sense of ‘place’ to it.”<br />
Building around that, the<br />
two have re-visioned and enclosed<br />
the structure using<br />
Brazilian koa wood, which<br />
glows from the road when<br />
west light is on it. They’ve<br />
installed large windows allowing<br />
in natural light, plus<br />
made interior spaces comfortable,<br />
yet secure.<br />
At the front lobby you’re<br />
greeted and checked for<br />
medical-use credentials. If<br />
you have them — or, in this<br />
case, are an invited, escorted<br />
guest — you’re admitted to<br />
the south-side sales room,<br />
which boasts diverse product<br />
displays, staff to assist you<br />
and fireplace in which orange<br />
tongues spring amid<br />
green stones.<br />
“Why the name Green<br />
Koi?” we asked.<br />
“It’s my spirit fish,” Setzke<br />
said. “To the Japanese, it’s a<br />
symbol for perseverance.”<br />
He and Del Stone have put<br />
work, thought and care into<br />
this.Both have healthcare<br />
experience: Setzke as a firefighter<br />
and paramedic, Del<br />
Stone as a massage therapist<br />
and in holistic medicine.<br />
Setzke has also owned multiple<br />
businesses; Del Stone<br />
has a real estate background<br />
and co-owns buildings in<br />
Chicago.<br />
“Finding real estate is key<br />
for operations like this,” Del<br />
Stone said. “You need the<br />
right place and zoning district<br />
with services available.”<br />
“You need good product<br />
line sources as well,” Setzke<br />
added. “We have six strains<br />
of flower, or bud, which are<br />
hard to find now in Michigan.<br />
Soon we’ll add a seventh.<br />
“You want a range of<br />
strains with different THC<br />
and CBD levels, plus edibles.<br />
We have gummies,<br />
chocolates, cookies, brownies,<br />
mints and will soon add<br />
beverages.<br />
“Topics, tinctures, concentrates<br />
&#8230; there’s demand for<br />
all of them,” Setzke said.<br />
Soon to open north of the<br />
front lobby will be a retail<br />
supplies store, “sort of what<br />
used to be called a head<br />
shop,” said Setzke. It will<br />
offer glassware, pipes, papers,<br />
vape products, Green<br />
Koi t-shirts and more marijuana<br />
accessories.<br />
Douglas City Council Feb.<br />
17 unanimously approved<br />
ordinances to permit and<br />
regulate adult use sales of<br />
recreational marijuana.<br />
“We will seek state and<br />
city licenses for that use<br />
too,” said Setzke. Should<br />
Green Koi obtain them, persons<br />
age 21 and older could<br />
buy retail marijuana products,<br />
but not medical ones<br />
without those particular credentials.<br />
“Both the state and our<br />
own shop software will have<br />
data bases to make sure of<br />
that,” Setzke said.<br />
“We’ve tried to create a<br />
beautiful space that is upscale,<br />
yet comfortable and<br />
relaxed, one in which people<br />
feel secure,” Del Stone said.<br />
“Valentine’s was our first<br />
day in business. We’re excited<br />
about what the future<br />
will hold,” he said.<br />
Green Koi is open daily,<br />
except for Tuesdays, from<br />
10 a.m. to 7 p.m. For more<br />
information, visit<br />
greenkoi420.com.</p>
	</div><!-- .entry-content -->

    
                                <div class='ad ads_single_bottom'><img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/03/b09639587a3a764fe6984bcdcc19c6f91.jpg"/></div>
        	    
    		
		<div class="cactus-share-and-like fix-bottom">
						<a class="share-tool-block open-cactus-share" data-toggle="tooltip" data-placement="top" href="javascript:;" title="" data-original-title="social share">
				<i class="fa fa-share-alt"></i>
				<i class="fa fa-times"></i>
							</a>
												
						
						<div class="clearfix"></div>
	
			<!--Share-->
								<ul class="social-listing list-inline change-color">
	  				  		<li class="facebook">
		  		 	<a class="trasition-all" title="Share on Facebook" href="#" target="_blank" rel="nofollow" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+'http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','facebook-share-dialog','width=626,height=436');return false;"><i class="fa fa-facebook"></i>
		  		 	</a>
		  		</li>
	    			    	<li class="twitter">
			    	<a class="trasition-all" href="#" title="Share on Twitter" rel="nofollow" target="_blank" onclick="window.open('http://twitter.com/share?text=Re-envisioned+carwash+is+new+marijuana+home&amp;url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','twitter-share-dialog','width=626,height=436');return false;"><i class="fa fa-twitter"></i>
			    	</a>
		    	</li>
	    					   	<li class="linkedin">
				   	 	<a class="trasition-all" href="#" title="Share on LinkedIn" rel="nofollow" target="_blank" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;title=Re-envisioned+carwash+is+new+marijuana+home&amp;source=The+Commercial+Record','linkedin-share-dialog','width=626,height=436');return false;"><i class="fa fa-linkedin"></i>
				   	 	</a>
				   	</li>
		   				   	<li class="tumblr">
			   	   <a class="trasition-all" href="#" title="Share on Tumblr" rel="nofollow" target="_blank" onclick="window.open('http://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;name=Re-envisioned+carwash+is+new+marijuana+home','tumblr-share-dialog','width=626,height=436');return false;"><i class="fa fa-tumblr"></i>
			   	   </a>
			   	</li>
	    			    	 <li class="google-plus">
		    	 	<a class="trasition-all" href="#" title="Share on Google Plus" rel="nofollow" target="_blank" onclick="window.open('https://plus.google.com/share?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','googleplus-share-dialog','width=626,height=436');return false;"><i class="fa fa-google-plus"></i>
		    	 	</a>
		    	 </li>
	    	 		    	 <li class="pinterest">
		    	 	<a class="trasition-all" href="#" title="Pin this" rel="nofollow" target="_blank" onclick="window.open('//pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;media=http%3A%2F%2Fwww.thecommercialrecord.com%2Fwp-content%2Fuploads%2F2020%2F02%2Fgreen-coy.jpg&amp;description=Re-envisioned+carwash+is+new+marijuana+home','pin-share-dialog','width=626,height=436');return false;"><i class="fa fa-pinterest"></i>
		    	 	</a>
		    	 </li>
	    	 		    	 <li class="vk">
		    	 	<a class="trasition-all" href="#" title="Share on VK" rel="nofollow" target="_blank" onclick="window.open('//vkontakte.ru/share.php?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','vk-share-dialog','width=626,height=436');return false;"><i class="fa fa-vk"></i>
		    	 	</a>
		    	 </li>
	    	 		    	<li class="email">
			    	<a class="trasition-all" href="mailto:?subject=Re-envisioned+carwash+is+new+marijuana+home&amp;body=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F" title="Email this"><i class="fa fa-envelope"></i>
			    	</a>
			   	</li>
		   		    </ul>
        						<!--Share-->
		</div>
	
		 
    <!--navigation post-->
    <div class="cactus-navigation-post">
    	        <div class="prev-post">
            <a href="http://www.thecommercialrecord.com/schools-offer-last-pre-vote-tours-saturday/" title="Schools offer last pre-vote tours Saturday">
                <span>previous</span>
                Schools offer last pre-vote tours Saturday            </a>
        </div>
                <div class="next-post">
            <a href="http://www.thecommercialrecord.com/police-investigate-laketown-death/" title="Police investigate Laketown death">
                <span>next</span>
                Police investigate Laketown death            </a>
        </div>
            </div>
    <!--navigation post-->
                                                <!--related post-->
    <div class="cactus-related-posts">
        <div class="title-related-post">
            Related Posts            <a class="pre-carousel" href="javascript:;"><i class="fa fa-angle-left"></i></a>
            <a class="next-carousel" href="javascript:;"><i class="fa fa-angle-right"></i></a>
            <div class="pagination"></div>
        </div>
        <div class="related-posts-content">

            <!--Listing-->
            <div class="cactus-listing-wrap">
                <!--Config-->
                <div class="cactus-listing-config style-1 style-3"> <!--addClass: style-1 + (style-2 -> style-n)-->

                    <div class="container">
                        <div class="row">

                            <div class="col-md-12 cactus-listing-content"> <!--ajax div-->

                                <div class="cactus-sub-wrap">
                                    <div class="cactus-swiper-container" data-settings='["mode":"cactus-fix-composer"]'>
                                        <div class="swiper-wrapper">
                                                                                        <div class="swiper-slide">
                                                <!--item listing-->
                                                <div class="cactus-post-item hentry">

                                                    <!--content-->
                                                    <div class="entry-content">
                                                        <div class="primary-post-content"> <!--addClass: related-post, no-picture -->

                                                            <!--picture-->
                                                            <div class="picture">
                                                                <div class="picture-content">
                                                                    <a href="http://www.thecommercialrecord.com/police-investigate-laketown-death/" title="Police investigate Laketown death">
                                                                        <img src="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Mandy-H-253x189.jpeg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Mandy-H-253x189.jpeg 253w, http://www.thecommercialrecord.com/wp-content/uploads/2020/02/Mandy-H-286x215.jpeg 286w"
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="Mandy H"/>                                                                        <div class="thumb-overlay"></div>
                                                                                                                                            </a>
                                                                </div>

                                                            </div><!--picture-->

                                                            <div class="content">

                                                                <!--Title-->
                                                                <h3 class="h6 cactus-post-title entry-title">
                                                                    <a href="http://www.thecommercialrecord.com/police-investigate-laketown-death/" title="Police investigate Laketown death">Police investigate Laketown death</a>
                                                                </h3><!--Title-->

                                                                <!--info-->
                                                                <div class="posted-on">
                                                                    <div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:21:49+00:00" class="entry-date updated">February 27, 2020</time></div>                                                                    <span class="vcard author"> 
                                                                        <span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" class="author cactus-info">Publisher</a></span>
                                                                    </span>
                                                                    <a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/#respond" class="comment cactus-info">0</a>

                                                                </div><!--info-->


                                                                <div class="cactus-last-child"></div> <!--fix pixel no remove-->
                                                            </div>
                                                        </div>

                                                    </div><!--content-->

                                                </div><!--item listing-->
                                            </div>
                                                                                        <div class="swiper-slide">
                                                <!--item listing-->
                                                <div class="cactus-post-item hentry">

                                                    <!--content-->
                                                    <div class="entry-content">
                                                        <div class="primary-post-content"> <!--addClass: related-post, no-picture -->

                                                            <!--picture-->
                                                            <div class="picture">
                                                                <div class="picture-content">
                                                                    <a href="http://www.thecommercialrecord.com/schools-offer-last-pre-vote-tours-saturday/" title="Schools offer last pre-vote tours Saturday">
                                                                        <img src="http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-253x168.jpg"
     			srcset="http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-253x168.jpg 253w, http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-250x165.jpg 250w, http://www.thecommercialrecord.com/wp-content/uploads/2017/12/sps-103x68.jpg 103w"
     			sizes="(max-width: 253px) 100vw, 253px"
				alt="sps"/>                                                                        <div class="thumb-overlay"></div>
                                                                                                                                            </a>
                                                                </div>

                                                            </div><!--picture-->

                                                            <div class="content">

                                                                <!--Title-->
                                                                <h3 class="h6 cactus-post-title entry-title">
                                                                    <a href="http://www.thecommercialrecord.com/schools-offer-last-pre-vote-tours-saturday/" title="Schools offer last pre-vote tours Saturday">Schools offer last pre-vote tours Saturday</a>
                                                                </h3><!--Title-->

                                                                <!--info-->
                                                                <div class="posted-on">
                                                                    <div class="cactus-info" rel="bookmark"><time datetime="2020-02-27T18:08:56+00:00" class="entry-date updated">February 27, 2020</time></div>                                                                    <span class="vcard author"> 
                                                                        <span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" class="author cactus-info">Publisher</a></span>
                                                                    </span>
                                                                    <a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/#respond" class="comment cactus-info">0</a>

                                                                </div><!--info-->


                                                                <div class="cactus-last-child"></div> <!--fix pixel no remove-->
                                                            </div>
                                                        </div>

                                                    </div><!--content-->

                                                </div><!--item listing-->
                                            </div>
                                                                                        <div class="swiper-slide">
                                                <!--item listing-->
                                                <div class="cactus-post-item hentry">

                                                    <!--content-->
                                                    <div class="entry-content">
                                                        <div class="primary-post-content"> <!--addClass: related-post, no-picture -->

                                                            <!--picture-->
                                                            <div class="picture">
                                                                <div class="picture-content">
                                                                    <a href="http://www.thecommercialrecord.com/douglas-za-imus-resigns/" title="Douglas ZA Imus resigns">
                                                                                                                                                <div class="thumb-overlay"></div>
                                                                                                                                            </a>
                                                                </div>

                                                            </div><!--picture-->

                                                            <div class="content">

                                                                <!--Title-->
                                                                <h3 class="h6 cactus-post-title entry-title">
                                                                    <a href="http://www.thecommercialrecord.com/douglas-za-imus-resigns/" title="Douglas ZA Imus resigns">Douglas ZA Imus resigns</a>
                                                                </h3><!--Title-->

                                                                <!--info-->
                                                                <div class="posted-on">
                                                                    <div class="cactus-info" rel="bookmark"><time datetime="2020-02-20T17:40:01+00:00" class="entry-date updated">February 20, 2020</time></div>                                                                    <span class="vcard author"> 
                                                                        <span class="fn"><a href="http://www.thecommercialrecord.com/author/publisher/" class="author cactus-info">Publisher</a></span>
                                                                    </span>
                                                                    <a href="http://www.thecommercialrecord.com/re-envisioned-carwash-is-new-marijuana-home/#respond" class="comment cactus-info">0</a>

                                                                </div><!--info-->


                                                                <div class="cactus-last-child"></div> <!--fix pixel no remove-->
                                                            </div>
                                                        </div>

                                                    </div><!--content-->

                                                </div><!--item listing-->
                                            </div>
                                                                                    </div>
                                    </div>

                                </div>

                            </div>

                        </div>
                    </div>

                </div><!--Config-->
            </div><!--Listing-->

        </div>
    </div>
    <!--related post-->
                                
                            </article>
                                                    </div>
                                                
                                            </div>

					<!--Sidebar-->
<div class="col-md-4 cactus-sidebar main-sidebar-col"> <!--addClass: left / right -> config sidebar position-->
	<div class="sidebar-content-fixed-scroll fixed-now">
		<aside id="text-5" class=" widget col-md-12 module widget-col widget_text"><div class="widget-inner">			<div class="textwidget"><a href="https://www.c21affiliated.com/tkerr"><img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/05/Kerr.jpg" style="width:100%;"/></a></div>
		</div></aside><aside id="text-10" class=" widget col-md-12 module widget-col widget_text"><div class="widget-inner">			<div class="textwidget"><a href="https://www.etypeservices.com/SWF/LocalUser/Kaechele1//Magazine276543/Full/index.aspx?II=276543"><img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/05/SDVG-2019-20-cover.jpg" style="width:100%;"/></a></div>
		</div></aside><aside id="text-11" class=" widget col-md-12 module widget-col widget_text"><div class="widget-inner">			<div class="textwidget"></div>
		</div></aside><aside id="text-7" class=" widget col-md-12 module widget-col widget_text"><div class="widget-inner">			<div class="textwidget"><a href="https://www.andreacrossman.com"><img src="http://www.thecommercialrecord.com/wp-content/uploads/2016/05/crossman.jpg" style="width:100%;"/></a></div>
		</div></aside><aside id="ws_fb_like_box-2" class=" widget col-md-12 module widget-col widget_ws_fb_like_box"><div class="widget-inner"><div class="fb-page ws-fb-like-box" data-href="https://www.facebook.com/thecommercialrecord" 
						data-tabs="timeline" 
						data-width="250" 
						data-height="500"
						data-small-header="false" 
						data-adapt-container-width="true" 
						data-hide-cover="false"
						data-show-posts=""
						data-show-facepile="true">
						<div class="fb-xfbml-parse-ignore">
							<blockquote cite="https://www.facebook.com/thecommercialrecord">
								<a href="https://www.facebook.com/thecommercialrecord">Facebook</a>
							</blockquote>
						</div>
					 </div> <div id="fb-root"></div>
					 <script>(function(d, s, id) {
					  var js, fjs = d.getElementsByTagName(s)[0];
					  if (d.getElementById(id)) return;
					  js = d.createElement(s); js.id = id;
					  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.6";
					  fjs.parentNode.insertBefore(js, fjs);
					}(document, 'script', 'facebook-jssdk'));</script></div></aside>  
    </div>  
</div>
<!--Sidebar-->
                </div><!--.row-->
            </div><!--.container-->
        </div><!--#cactus-single-page-->
    </div><!--#cactus-body-container-->


    <footer>
        <div class="footer-inner dark-div">
                    </div><!--.footer-inner-->
        
        <div class="footer-info dark-div">
            <div class="container">
                <div class="row">                        
                    <div class="col-md-6 col-sm-6 copyright font-1">Copyright 2016 The Commercial Record</div>
                    <div class="col-md-6 col-sm-6 link font-1">
                      <div class="menu-footer-menu-container">
                          <ul id="menu-footer-menu" class="menu">
                                                      </ul>
                       </div>
                    </div>
                </div>
            </div>
        </div>
        
    </footer>
            
	</div><!--#wrap-->
        
    <!--Menu moblie-->
    <div class="canvas-ovelay"></div>
    <div id="off-canvas" class="off-canvas-default dark-div">
        <div class="off-canvas-inner">
            <div class="close-canvas-menu">
                <i class="fa fa-times"></i> Close
            </div>
            <nav class="off-menu">
                <ul>                        	
                    <li id="menu-item-128" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-128"><a href="http://www.thecommercialrecord.com/">Home</a></li>
<li id="menu-item-129" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children parent menu-item-129"><a href="http://www.thecommercialrecord.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-7026" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7026"><a href="http://www.thecommercialrecord.com/category/news/sports/aroundtownsports/">Around Town</a></li>
	<li id="menu-item-7024" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7024"><a href="http://www.thecommercialrecord.com/category/news/localnews/">Local</a></li>
	<li id="menu-item-7028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7028"><a href="http://www.thecommercialrecord.com/category/contributed/">Contributed</a></li>
</ul>
</li>
<li id="menu-item-6995" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6995"><a href="http://www.thecommercialrecord.com/category/news/sports/">Sports</a></li>
<li id="menu-item-6996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6996"><a href="http://www.thecommercialrecord.com/category/opinion/">Opinion</a></li>
<li id="menu-item-6997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6997"><a href="http://www.thecommercialrecord.com/obituaries/">Obituaries</a></li>
<li id="menu-item-6998" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6998"><a href="http://www.allegannews.com/">Allegan News</a></li>
<li id="menu-item-6999" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6999"><a href="http://www.allegannews.com/union-enterprise">Union Enterprise</a></li>
<li id="menu-item-7782" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-7782"><a href="http://www.thecommercialrecord.com/category/classified/">Classified</a></li>
                      
                </ul>
                
                <ul class="search-mobile-menu">
                    <li>
                        <form action="http://www.thecommercialrecord.com" method="get">
                            <input type="text" placeholder="Search..." name="s" value="">
                            <i class="fa fa-search"></i>
                            <input type="submit" value="search">
                        </form>
                    </li>
                </ul>
                
            </nav>
        </div>
    </div><!--Menu moblie-->
    
    <div class="go-to-top">
    	<i class="fa fa-angle-up"></i>
    </div>
    <div class="popup_share_overlay"></div>
    <div class="popup_share_video_wrapper">
    	<div class="popup_share_video">
    		<h4>Share this video</h4>
    				<ul class="social-listing list-inline change-color popup_share_video_listing">
	  				  		<li class="facebook">
		  		 	<a class="trasition-all" title="Share on Facebook" href="#" target="_blank" rel="nofollow" onclick="window.open('https://www.facebook.com/sharer/sharer.php?u='+'http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','facebook-share-dialog','width=626,height=436');return false;"><i class="fa fa-facebook"></i>
		  		 	</a>
		  		</li>
	    			    	<li class="twitter">
			    	<a class="trasition-all" href="#" title="Share on Twitter" rel="nofollow" target="_blank" onclick="window.open('http://twitter.com/share?text=Re-envisioned+carwash+is+new+marijuana+home&amp;url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','twitter-share-dialog','width=626,height=436');return false;"><i class="fa fa-twitter"></i>
			    	</a>
		    	</li>
	    					   	<li class="linkedin">
				   	 	<a class="trasition-all" href="#" title="Share on LinkedIn" rel="nofollow" target="_blank" onclick="window.open('http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;title=Re-envisioned+carwash+is+new+marijuana+home&amp;source=The+Commercial+Record','linkedin-share-dialog','width=626,height=436');return false;"><i class="fa fa-linkedin"></i>
				   	 	</a>
				   	</li>
		   				   	<li class="tumblr">
			   	   <a class="trasition-all" href="#" title="Share on Tumblr" rel="nofollow" target="_blank" onclick="window.open('http://www.tumblr.com/share/link?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;name=Re-envisioned+carwash+is+new+marijuana+home','tumblr-share-dialog','width=626,height=436');return false;"><i class="fa fa-tumblr"></i>
			   	   </a>
			   	</li>
	    			    	 <li class="google-plus">
		    	 	<a class="trasition-all" href="#" title="Share on Google Plus" rel="nofollow" target="_blank" onclick="window.open('https://plus.google.com/share?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','googleplus-share-dialog','width=626,height=436');return false;"><i class="fa fa-google-plus"></i>
		    	 	</a>
		    	 </li>
	    	 		    	 <li class="pinterest">
		    	 	<a class="trasition-all" href="#" title="Pin this" rel="nofollow" target="_blank" onclick="window.open('//pinterest.com/pin/create/button/?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F&amp;media=http%3A%2F%2Fwww.thecommercialrecord.com%2Fwp-content%2Fuploads%2F2020%2F02%2Fgreen-coy.jpg&amp;description=Re-envisioned+carwash+is+new+marijuana+home','pin-share-dialog','width=626,height=436');return false;"><i class="fa fa-pinterest"></i>
		    	 	</a>
		    	 </li>
	    	 		    	 <li class="vk">
		    	 	<a class="trasition-all" href="#" title="Share on VK" rel="nofollow" target="_blank" onclick="window.open('//vkontakte.ru/share.php?url=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F','vk-share-dialog','width=626,height=436');return false;"><i class="fa fa-vk"></i>
		    	 	</a>
		    	 </li>
	    	 		    	<li class="email">
			    	<a class="trasition-all" href="mailto:?subject=Re-envisioned+carwash+is+new+marijuana+home&amp;body=http%3A%2F%2Fwww.thecommercialrecord.com%2Fre-envisioned-carwash-is-new-marijuana-home%2F" title="Email this"><i class="fa fa-envelope"></i>
			    	</a>
			   	</li>
		   		    </ul>
            	</div>
    </div>
               
	</div><!--#body-wrap-->
    <script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/newstube-shortcodes/shortcodes/js/shortcode.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/newstube-shortcodes/shortcodes/library/touchswipe/jquery.touchSwipe.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/mouse.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/resizable.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/draggable.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/button.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/jquery/ui/dialog.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/wpdialog.min.js'></script>
<script type='text/javascript' src='//f.vimeocdn.com/js/froogaloop2.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-ads/js/screenfull.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-ads/js/video-ads-management.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-poll/js/cactus-poll.js'></script>
<script type='text/javascript' src='https://www.google.com/recaptcha/api.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-rating/js/main.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-rating/js/wow.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-rating/js/jquery.raty-fa.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"loaderUrl":"http:\/\/www.thecommercialrecord.com\/wp-content\/plugins\/contact-form-7\/images\/ajax-loader.gif","recaptchaEmpty":"Please verify that you are not a robot.","sending":"Sending ...","cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/contact-form-7/includes/js/scripts.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mashmenu = {"ajax_url":"http:\/\/www.thecommercialrecord.com\/wp-admin\/admin-ajax.php","ajax_loader":"on","ajax_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/inc/megamenu/js/mashmenu.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/bootstrap.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/swiper/idangerous.swiper.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/swiper/idangerous.swiper.progress.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/imagesloaded.pkgd.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/malihu-scroll/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/jquery.ba-throttle-debounce.min.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/themes/newstube/js/template.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-content/plugins/cactus-channel/js/custom.js'></script>
<script type='text/javascript' src='http://www.thecommercialrecord.com/wp-includes/js/wp-embed.min.js'></script>
     
</body>
</html>

<!-- Performance optimized by W3 Total Cache. Learn more: http://www.w3-edge.com/wordpress-plugins/

 Served from: www.thecommercialrecord.com @ 2020-02-27 18:25:41 by W3 Total Cache -->